Главная Мой профиль Регистрация Выход Вход
Приветствую Вас Гость | RSS
Понедельник
23.10.2017
09:02
Установка Игр в Ubuntu
[ Новые сообщения · Участники · Правила форума · Поиск · RSS ]
Страница 1 из 11
Форум » Запуск windows игр и приложений в среде Ubuntu » Windows программы в Ubuntu: установка и настройка » Не устанавливается dotnet35sp1
Не устанавливается dotnet35sp1
MarДата: Четверг, 12.02.2015, 15:50 | Сообщение # 1
Новичок
Группа: Пользователи
Сообщений: 2
Репутация: 0
Статус: Offline
Добрый день!

Пробую установить dotnetsp1 как написано в инструкции на данном сайте. Ничего не получается. Вылетает с ошибкой постоянно, что не установлен dotnet30.
Конфигурация системы: ubuntu 14.04 и wine 1.6.2

Есть идеи как победить?
 
SolitonДата: Пятница, 13.02.2015, 09:53 | Сообщение # 2
Модератор
Группа: Администраторы
Сообщений: 241
Репутация: 13
Статус: Offline
Что за dotnetsp1 (есть dotnet20sp1, dotnet30sp1, dotnet35sp1) ?
Для NET Framework 3.5 SP1 (dotnet35sp1) нужны установленные NET Framework 2.0 SP2 (dotnet20sp2) и NET Framework 3.0 (dotnet30), которые в свою очередь потянут другие библиотеки - в общем "геморрой". А что за необходимость именно в NET 3.5 SP1 ?, поставьте NET 4.0 (dotnet40) на более новую версию Wine.
 
MarДата: Понедельник, 16.02.2015, 10:16 | Сообщение # 3
Новичок
Группа: Пользователи
Сообщений: 2
Репутация: 0
Статус: Offline
Soliton, конечно речь идет о dotnet35sp1. Ставил по инструкции = установил все как написано (включая установку dotnet20sp2).
Ставил dotnet40, но мне 35нужен для работы VMware Vshpere Client 5.5 update 2. Инсталятор вмваревский запускает установку .NET 35

И wine стабильная версия именно 1.6.2.


Сообщение отредактировал Mar - Понедельник, 16.02.2015, 10:17
 
SolitonДата: Четверг, 19.02.2015, 00:01 | Сообщение # 4
Модератор
Группа: Администраторы
Сообщений: 241
Репутация: 13
Статус: Offline
Установка .NET Framework 3.5 SP1 в Wine на Ubuntu 14.04

Исходные данные:
Ubuntu 14.04 64-bit
Wine-1.7.31 (POL - версия)
Версию Wine и чистый префикс устанавливал как дополнительные, через свой скрипт (см. на сайте - установку дополнительных версий Wine)

Устанавливаем через GUI winetricks (поочередно):
1) corefonts
2) msxl3
3) dotnet35sp1
... дальше пойдет сам процесс установки (ни куда не уходим smile ), а именно
.NET Framework 2.0
.NET Framework 3.0
.NET Framework 2.0 SP1 (в конце тыкаем "перезагрузить позже")
XPS Essentialss Pack Setup Wizard (тыкаем без регистрации)
.NET Framework 3.0 SP1
.NET Framework 3.5
.NET Framework 2.0 SP2 (в конце тыкаем "перезагрузить позже")
.NET Framework 3.5 SP1
Установилось, как ни странно, довольно удачно.
P/S  В процессе установки будут выскакивать различные предупреждения, просто соглашаемся - OK. Да, желательно чтобы все устанавливаемые пакеты уже находились в ./cache/winetrcks, иначе установка будет прервана для скачки этих компонентов и как пойдет дальше не известно?!
 
Форум » Запуск windows игр и приложений в среде Ubuntu » Windows программы в Ubuntu: установка и настройка » Не устанавливается dotnet35sp1
Страница 1 из 11
Поиск:


 Copyright MyCorp © 2017
Сделать бесплатный сайт с uCoz