Главная Мой профиль Регистрация Выход Вход
Приветствую Вас Гость | RSS
Понедельник
26.06.2017
15:07
Установка Игр в Ubuntu
[ Новые сообщения · Участники · Правила форума · Поиск · RSS ]
Страница 1 из 11
Форум » Запуск windows игр и приложений в среде Ubuntu » Wine в Ubuntu: установка и настройка » Не компилируется Wine
Не компилируется Wine
aronsxДата: Четверг, 03.05.2012, 07:23 | Сообщение # 1
Новичок
Группа: Пользователи
Сообщений: 2
Репутация: 1
Статус: Offline
Пытаюсь скомпилировать вайн по гайду с этого сайта.
вайн 1.5.2; система ubuntu 12.04 amd64

изначально выйн выдавал такую ошибку:
Cannot build a 32-bit program, you need to install 32-bit development libraries.
потом я в синаптике ввел в поиск lib32*dev и поставил все что нашел

теперь у меня выдает такую ошибку:

checking for X... no
configure: error: X 32-bit development files not found. Wine will be built
without X support, which probably isn't what you want. You will need
to install 32-bit development packages of Xlib/Xfree86 at the very least.
Use the --without-x option if you really want this.

помогите, что делать?
P.S. пытался найти в синаптике и в гугле Xlib и Xfree86. безрезультатно. находил только Xfree86 в rpm пакете.
скажите, что надр ставить и ткните носом где взять?
 
SolitonДата: Пятница, 04.05.2012, 15:23 | Сообщение # 2
Модератор
Группа: Администраторы
Сообщений: 241
Репутация: 13
Статус: Offline
С компиляцией 1.5 пока проблемы. Вообще - 12.04 еще не ставил, как перейду (думаю в скором времени), "накидаю" обновленный хелп.
 
IGOДата: Вторник, 24.07.2012, 20:40 | Сообщение # 3
Любитель
Группа: Пользователи
Сообщений: 32
Репутация: 1
Статус: Offline
Тебе делать нечего.Готовую лень установить? biggrin
 
SolitonДата: Суббота, 18.08.2012, 12:38 | Сообщение # 4
Модератор
Группа: Администраторы
Сообщений: 241
Репутация: 13
Статус: Offline
Quote (aronsx)
configure: error: X 32-bit development files not found. Wine will be built
without X support, which probably isn't what you want. You will need
to install 32-bit development packages of Xlib/Xfree86 at the very least.
Use the --without-x option if you really want this.


Вот метод решения проблемы:
Компиляция 32-bit Wine на 64-bit Ubuntu 12.04
 
DiableroДата: Четверг, 03.04.2014, 21:04 | Сообщение # 5
Новичок
Группа: Пользователи
Сообщений: 2
Репутация: 0
Статус: Offline
Всем привет! Хотел спросить по поводу компиляции. У меня Ubuntu 10.04, скомпилировал wine по инструкции с вашего сайта, но мне доступна только версия 1.4. Так вот хотел узнать можно ли скомпилировать версии выше 1.4? Например 1.7? В сети  пишут что нельзя, а полного ответа не смог найти. Если нельзя, то почему? Не верится что нельзя, это же линукс!:)
 
SolitonДата: Пятница, 04.04.2014, 09:36 | Сообщение # 6
Модератор
Группа: Администраторы
Сообщений: 241
Репутация: 13
Статус: Offline
Цитата Diablero ()
У меня Ubuntu 10.04

10.04 последняя вменяемая версия Ubuntu, дальше пошло какое то непотребство, но к сожалению она (Ubuntu 10.04) уже давно без тех. поддержки, так что пора определяться: или ставить Ubuntu 12.04/14.04, или при неприязни оных переходить на другой дистрибутив (Fedora, Debian ...).

Цитата Diablero ()
но мне доступна только версия 1.4. Так вот хотел узнать можно ли скомпилировать версии выше 1.4? Например 1.7? В сети пишут что нельзя, а полного ответа не смог найти. Если нельзя, то почему? Не верится что нельзя, это же линукс!:)

Я так понял, компиляция Wine нужна вам чтоб установить более новую, неподдерживаемую Ubuntu-ой 10.04, версию Wine. В новых версиях как самой Ubuntu, так и WIne, поменялось расположение некоторых библиотек (или структура каталогов), поэтому при компиляции будут вылетать ошибки отсутствия библиотек, хотя последние могут и присутствовать, но находиться будут в других местах (папках). Компиляция превратится в геморрой smile

Как вариант выхода из вашей ситуации, попробуйте воспользоваться скриптом установки дополнительных версий Wine
 
DiableroДата: Понедельник, 07.04.2014, 18:52 | Сообщение # 7
Новичок
Группа: Пользователи
Сообщений: 2
Репутация: 0
Статус: Offline
Спасибо за вразумительный ответ!:)
Про этот скрипт знаю и уже использую его, но всё же хотелось чтобы можно было компилировать именно под свою машину wine, для максимальной производительности, т.к. компьютер слабоват по текущим меркам - Asus A8V, Opteron 185, 4GB DDR, GeForce 7950 GT AGP 512.

Добавлено (07.04.2014, 18:52)
---------------------------------------------
Вот что ещё нашёл, но проверить к сожалению не могу. В Wine добавили нативную поддержку Direct3D 9.

 
SolitonДата: Среда, 09.04.2014, 12:07 | Сообщение # 8
Модератор
Группа: Администраторы
Сообщений: 241
Репутация: 13
Статус: Offline
Цитата Diablero ()
Вот что ещё нашёл, но проверить к сожалению не могу. В Wine добавили нативную поддержку Direct3D 9.

В принципе, моя видюха GeForce GTS 250, из серии NV50, поддерживается Nouveau, но
для этого мне надо удалить проприетарный драйвер NVIDIA, скомпилировать и установить свободный Nouveau видеодрайвер, а уж потом компилить патченный Wine.

Однако, я так понял, фраза "Работает это только с Gallium3D-драйверами nouveau (nvc0, NVIDIA), r600g (AMD), swrast и, возможно, i915g" означает, что этот wine работает только с серией NVC0 для NVIDIA, моя видеокарта (из серии NV50) в нее не входит, поэтому смысла пробовать не вижу.
 
FloumenДата: Четверг, 23.10.2014, 01:40 | Сообщение # 9
Любитель
Группа: Пользователи
Сообщений: 16
Репутация: 0
Статус: Offline
Пишет:
Cannot build a 32-bit program, you need to install 32-bit development libraries.

Какие конкретно нужно устанавливать пакеты, что бы не устанавливать все подряд


Добавлено (22.10.2014, 21:12)
---------------------------------------------
Вроде всё сделал... компиляция прошла, но в конце прописало несколько Warning-ов по поводу каких то 32бит ных пакетов (not found). надеюсь это не страшно. Что вы скажите про другие 2 способа компиляции 32 битного вайн в 64 битной Убунту?
http://wiki.winehq.org/WineOn64bit

Добавлено (23.10.2014, 01:40)
---------------------------------------------
То что скомпилированно работает! Ура.. но есть проблемма другая:

Как одновременно запускать оба вайна? у меня сервер стоит на пропатченом вайне, другой без пропатченого вайна, игру запускаю тоже без пропатченого вайна, но чтобы запустить игру мне приходится прописывать WINESERVER -k, чтобы убить процесы пропатчено вайна, для запуска обычного =(,

или как сделать что бы работало два wijneserver-а? как переименовать второй? чтобы например процес назывался "wineserver2" или какие ещё способы есть?


Сообщение отредактировал Floumen - Четверг, 23.10.2014, 01:42
 
oleg123Дата: Воскресенье, 06.11.2016, 21:25 | Сообщение # 10
Новичок
Группа: Пользователи
Сообщений: 4
Репутация: 0
Статус: Offline
Здравствуйте уважаемые друзья. 

Представляю Вам уникальный ресурс, на котором Вы
сможете: 
1. Проверить мошенников по огромной базе и не
быть обманутыми: garantmarket.net/4s.html 

2.Разместить своё объявление о покупке/продаже
обмене игровыми ценностями, аккаунтами во всех онлайн играх. 
Посмотреть объявления Вы можете тут: garantmarket.net/doski.html 
Разместить объявление может каждый и это
бесплатно, а так же после размещения оно дублируется в 8 соц медиа. 

3. Воспользоваться услугами профессионального
гаранта, который поможет Вам в любой операции в интернете, будь то покупка,
продажа чего либо, или обмен. 
Гаранты выступают в виде посредников сделки
между продавцом и покупателем, тем самым гарантируя порядочность проведения
сделки при
покупке/продаже/обмен/споре/заказе/контракте/договоре/кредите/переводе/отправке/пересылке/переносе/прочие.
Мы занимаемся порядком 200 видов различной деятельности, где предоставляем
услуги гаранта, по безопасным сделкам) garantmarket.net/garant.html 

И многое другое, что будетполезно пользователям интернета.
 
Форум » Запуск windows игр и приложений в среде Ubuntu » Wine в Ubuntu: установка и настройка » Не компилируется Wine
Страница 1 из 11
Поиск:


 Copyright MyCorp © 2017
Сделать бесплатный сайт с uCoz